<!DOCTYPE html>
<html xmlns="http://www.w3.org/1999/xhtml">
<head>
<meta charset="utf-8"/>
<meta content="IE=Edge" http-equiv="X-UA-Compatible"/>
<meta content="width=device-width, initial-scale=1.0" name="viewport"/>
<meta content="#571963" name="theme-color"/>


<link href="http://www.mccormick.northwestern.edu/news/articles/2018/02/new-machine-learning-algorithm-uncovers-time-delayed-interactions-in-gene-regulatory-systems.html" rel="canonical"/><meta content="article" property="og:type"/><meta content="http://www.mccormick.northwestern.edu/news/articles/2018/02/new-machine-learning-algorithm-uncovers-time-delayed-interactions-in-gene-regulatory-systems.html" property="og:url"/><meta content="Northwestern Engineering" property="og:site_name"/><meta content="http://www.mccormick.northwestern.edu/images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-fb.jpg" property="og:image"/><meta content="New algorithm uses time-series data to show the cause-and-effect interactions that take place inside of living cells." property="og:description"/><meta content="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems" property="og:title"/><meta content="https://www.facebook.com/mccormickengineering" property="article:publisher"/><meta content="New algorithm uses time-series data to show the cause-and-effect interactions that take place inside of living cells." name="og:description"/><meta content="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems" name="og:title"/><meta content="New algorithm uses time-series data to show the cause-and-effect interactions that take place inside of living cells." name="description"/><meta content="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems" name="title"/><meta content="summary_large_image" name="twitter:card"/><meta content="@NU_McCormick" name="twitter:site"/><meta content="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems" name="twitter:title"/><meta content="New algorithm uses time-series data to show the cause-and-effect interactions that take place inside of living cells." name="twitter:description"/><meta content="http://www.mccormick.northwestern.edu/images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-fb.jpg" name="twitter:image"/><meta content="../../../../images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-fb.jpg" name="publish-social-image"/><meta content="../../../../images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-s.jpg" name="publish-sliders-image"/><meta content="../../../../images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-tn.jpg" name="publish-thumbnail"/><meta content="marketing" name="news_source"/><meta content="Chemical and Biological Engineering" name="news_departments"/><meta content="" name="eecs_divisions"/><meta content="1518462000000" name="publish_time"/><meta content="02-12-18" name="publication_date"/><meta content="Research" name="primary_category"/><meta content="Research|Research" name="categories"/><meta content="2018" name="news_year"/><meta content="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems" name="title"/><meta content="New algorithm uses time-series data to show the cause-and-effect interactions that take place inside of living cells." name="summary"/><meta content="/images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-tn.jpg" name="thumbnail_path"/><meta content="Feb 12, 2018" name="news_date"/>
<meta content="" name="sitetype"/>
<title>New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems | News | Northwestern Engineering
                    </title>
<link href="../../../../images/structure/favicon.png" rel="icon" type="image/png"/>



<link href="/css/normalize.css" media="screen" rel="stylesheet"/>
<link href="/css/jquery/jquery-slick.css" media="screen" rel="stylesheet"/>
<link href="/css/default.css" media="screen" rel="stylesheet"/>
<link href="/css/layout.css" media="screen" rel="stylesheet"/>
<link href="/css/layout-print.css" media="print" rel="stylesheet"/>
<script src="//code.jquery.com/jquery-1.11.0.min.js" type="text/javascript"></script>
<script src="//code.jquery.com/jquery-migrate-1.2.1.min.js" type="text/javascript"></script>
<script src="/js/jquery/jquery-footable.min.js" type="text/javascript">
</script>


<link href="../../../../css/news-article.css" rel="stylesheet"/>
<script type="text/javascript">

var addthis_config = {
    // ui_use_css: false, // bad idea, don't ever do this
    pubid: "ra-537584620b2ec41c",
    data_track_clickback: false,
    data_ga_property: 'UA-3977631-1',
    data_ga_social : true
};

//var addthis_scriptUrl = "//s7.addthis.com/js/250/addthis_widget.js#pubid=xa-4f97114f6391bae4";
var addthis_scriptUrl = "//s7.addthis.com/js/250/addthis_widget.js#pubid=ra-537584620b2ec41c";
var addthis_share = {
    url_transforms : {
        shorten: {
            twitter: 'bitly'
        }
    },
    shorteners : {
        bitly : {}
    }
}

</script>
 
</head>
    <body> 
        <script>
            dataLayer = [{
                'pageType' : 'news, main site',
                'pageProgramType' : 'none',
                'academicAos' : 'none',
                'academicDept':'',
                'academicProg':'',
                'academicUnit' : 'mccormick',
                
                'event':'e_articleImpression',
                'articleTitle':'New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems',
                'articleAuthor':'Amanda Morris',
                'articleCategory':'Research, Research',
                'articlePublishDate':'02/12/18',
                'articleTags':'Chemical and Biological Engineering'
                }];
        </script>
        <!-- Google Tag Manager -->
 
<noscript><iframe src="//www.googletagmanager.com/ns.html?id=GTM-KX6F23&gtm_auth=wMILQr1-arU9JWeIZPlVAQ&gtm_preview=env-1&gtm_cookies_win=x"
height="0" width="0" style="display:none;visibility:hidden"></iframe></noscript>
<script>(function(w,d,s,l,i){w[l]=w[l]||[];w[l].push({'gtm.start':
new Date().getTime(),event:'gtm.js'});var f=d.getElementsByTagName(s)[0],
j=d.createElement(s),dl=l!='dataLayer'?'&l='+l:'';j.async=true;j.src=
'//www.googletagmanager.com/gtm.js?id='+i+dl+'&gtm_auth=wMILQr1-arU9JWeIZPlVAQ&gtm_preview=env-1&gtm_cookies_win=x';f.parentNode.insertBefore(j,f);
})(window,document,'script','dataLayer','GTM-KX6F23');</script>

<!-- End Google Tag Manager -->
        <header role="banner">
            <div id="mobile-menu">
                <div id="mobile-menu-handle"></div>
            </div>
            <div id="northwestern-logo-wrapper-outer">
                <div id="northwestern-logo-wrapper">
                    <a href="http://www.northwestern.edu" id="northwestern-logo" target="_blank"><img alt="Northwestern University" class="desktop" src="../../../../images/structure/sprites/northwestern-logo-global-nav.svg"/><img alt="Northwestern University" class="mobile" src="../../../../images/structure/sprites/northwestern-logo-global-nav-small.svg"/></a>
                </div>
            </div>
            <div id="super-header">
                <div class="header-container">
                    <div class="cf" id="super-nav">
                        <ul>
    <li>INFO FOR</li>
    <li>
        <a href="../../../../students/index.html">Students</a>
    </li>
    <li>
        <a href="http://www.mccormick.northwestern.edu/faculty-staff-resources/index.html">Faculty &amp; Staff</a>
    </li>
    <li>
        <a href="../../../../alumni/index.html">Alumni</a>
    </li>
    <li>
        <a href="http://www.mccormick.northwestern.edu/corporate-engagement/index.html">Companies</a>
    </li>
    <li class="right">
        <a href="../../../../news-events/index.html">News &amp; Events</a>
    </li>
    <li class="right">
        <a href="../../../../contact/index.html">Contact &amp; Visit</a>
    </li>
</ul>
                    </div>
                </div>
            </div>
            <div id="mid-header">
                <div class="header-container">
                    <a class="mccormick-header-logo" href="../../../../index.html"><img alt="McCormick School of Engineering" class="desktop" src="../../../../images/structure/engineering-logo.svg"/><img alt="McCormick School of Engineering" class="mobile" src="../../../../images/structure/engineering-logo-mobile.svg"/></a>
                    <div id="banner-search"></div>
                </div>
            </div>
            <div id="nav">
                <div class="header-container">
                    <ul id="top-nav"><li><a href="../../../../about/index.html">About</a><div><div class="hover-container"><div class="intro"><a class="hover-header" href="../../../../about/index.html">ABOUT</a><small>Leadership, facts, and figures about McCormick</small></div><ul><li><a href="../../../../about/index.html">Overview</a></li><li><a href="../../../../about/leadership/index.html">Leadership</a></li><li><a href="../../../../about/departments-institutes.html">Departments &amp; Institutes</a></li><li><a href="../../../../about/facilities.html">Facilities</a></li><li><a href="../../../../about/history.html">History</a></li><li><a href="../../../../about/facts.html">Facts</a></li><li><a href="../../../../about/faculty-journal-covers.html">Faculty Journal Covers</a></li></ul><div class="outro"><a class="highlight" href="../../../../explore/index.html">Explore McCormick</a></div></div></div></li><li><a href="../../../../academics/index.html">Academics</a><div><div class="hover-container"><div class="intro"><a class="hover-header" href="../../../../academics/index.html">ACADEMICS</a><small>Areas of study and admissions information</small></div><ul><li><a href="../../../../academics/index.html">Academics Overview</a></li><li><a href="../../../../academics/undergraduate/index.html">Undergraduate Study</a></li><li><a href="../../../../academics/graduate/index.html">Graduate Study</a></li><li><a href="../../../../academics/all-areas-of-study.html">All Areas of Study</a></li><li><a href="../../../../academics/departments.html">Departments</a></li><li><a href="../../../../academics/apply.html">Apply to McCormick</a></li></ul><div class="outro"><a class="highlight" href="../../../../students/index.html">Current Student Resources</a></div></div></div></li><li><a href="../../../../research-faculty/index.html">Research &amp; Faculty</a><div><div class="hover-container"><div class="intro"><a class="hover-header" href="../../../../research-faculty/index.html">RESEARCH &amp; FACULTY</a><small>Research overview, centers, and faculty directory</small></div><ul><li><a href="../../../../research-faculty/index.html">Research Areas and Centers</a></li><li><a href="../../../../research-faculty/directory/index.html">Faculty Directory</a></li></ul><div class="outro"><span class="highlight">Find Faculty <form action="../../../../research-faculty/directory/index.html" method="get"><input name="keyword" placeholder="Enter name or keyword" type="text"/></form></span></div></div></div></li><li><a href="../../../../offices-services/index.html">Offices &amp; Services</a><div><div class="hover-container"><div class="intro"><a class="hover-header" href="../../../../offices-services/index.html">OFFICES &amp; SERVICES</a><small>Administrative offices and services for all parties</small></div><ul><li><a href="../../../../about/departments-institutes.html#departments">Academic Departments</a></li><li><a href="../../../../offices-services/index.html#admin">Administration, Finance, Facilities &amp; Planning</a></li><li><a href="../../../../offices-services/index.html#alumni">Alumni Relations &amp; Development</a></li><li><a href="http://www.mccormick.northwestern.edu/career-development/index.html">Career Development</a></li><li><a href="http://www.mccormick.northwestern.edu/corporate-engagement/index.html">Corporate Engagement</a></li><li><a href="http://www.mccormick.northwestern.edu/services/index.html">Customer Service Center</a></li><li><a href="../../../../offices-services/index.html#faculty">Faculty Affairs</a></li><li><a href="http://www.mccormick.northwestern.edu/global/index.html">Global Initiatives</a></li><li><a href="../../../../offices-services/index.html#graduate">Graduate Studies</a></li><li><a href="http://www.mccormick.northwestern.edu/it-resources/index.html">Information Technology</a></li><li><a href="http://www.mccormick.northwestern.edu/marketing/index.html">Marketing &amp; Communications</a></li><li><a href="../../../../offices-services/index.html#advising">McCormick Advising System</a></li><li><a href="../../../../offices-services/index.html#dean">Office of the Dean</a></li><li><a href="http://www.mccormick.northwestern.edu/personal-development/index.html">Personal Development</a></li><li><a href="../../../../offices-services/index.html#research">Research Offices</a></li><li><a href="../../../../offices-services/index.html#undergraduate">Undergraduate Engineering</a></li></ul></div></div></li><li id="nav-search"><a class="icon-search-glass" href="http://googlesearch.northwestern.edu/search?site=mcc&amp;client=mcc&amp;output=xml_no_dtd&amp;proxystylesheet=mcc2014&amp;filter=0">web search</a><div><div class="hover-container"><form action="http://googlesearch.northwestern.edu/search" id="web-search" method="get"><input name="site" type="hidden" value="mcc"/><input name="client" type="hidden" value="mcc"/><input name="output" type="hidden" value="xml_no_dtd"/><input name="proxystylesheet" type="hidden" value="mcc2014"/><input name="filter" type="hidden" value="0"/><input autocomplete="off" id="q" name="q" placeholder="Search this site" type="search"/></form></div></div></li><li id="top-nav-explore"><a href="../../../../explore/index.html">Explore</a></li></ul>
                </div>
            </div>
            <h1 id="major-title">
                <span class="header-container">
                    <a href="../../../../news-events/index.html">News &amp; Events</a>
                    <span class="extraneous">, McCormick School of Engineering, Northwestern University</span>
                </span>
            </h1>
        </header>
        <div id="container">
            <article role="main">
                <div id="page-title" xmlns:addthis="http://www.addthis.com/help/api-spec">ENGINEERING NEWS</div><div class="news-main" id="main-content" xmlns:addthis="http://www.addthis.com/help/api-spec"><div id="news-article-content"><div class="categories"><a href="../../../search.php?category=Research">Research</a></div><h1>New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems</h1><h2>New algorithm uses time-series data to uncover underlying biological networks</h2><div class="newsarticle_dateline"><span class="date">Feb 12, 2018</span> // <div class="author">Amanda Morris</div></div><div class="slider news-slider slick-slider single-image"><img alt="SWING puts together a more complete picture of cause-and-effect interactions among genes." class="slider-img" src="../../../../images/news/2018/02/new-machine-algorithm-uncovers-time-delayed-interactions-h.jpg"/><span class="caption">SWING puts together a more complete picture of cause-and-effect interactions among genes.</span></div><div id="news_story"><div class="addthis"><div addthis:title="New Machine Learning Algorithm Uncovers Time-Delayed Interactions in Gene Regulatory Systems | Northwestern Engineering" addthis:url="http://www.mccormick.northwestern.edu/news/articles/2018/02/new-machine-learning-algorithm-uncovers-time-delayed-interactions-in-gene-regulatory-systems.html" class="addthis_toolbox addthis_floating_style addthis_32x32_style" style="left: 0;top: 0;"><a class="addthis_button_twitter"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a><a class="addthis_button_facebook"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a><a class="addthis_button_google_plusone_share"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a><a class="addthis_button_email"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a><a class="addthis_button_print"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a><a class="addthis_button_compact"><img class="addImg" src="../../../../images/structure/news-share-vide.gif"/></a></div><script type="text/javascript">
            
            if (window.addthis) {
                window.addthis = null; 
                window._adr = null;
                window._atc = null;
                window._atd = null;
                window._ate = null;
                window._atr = null;
                window._atw = null;
            }
            $.ajax({
                dataType: "script",
                cache: true,
                url: addthis_scriptUrl
            });
            
        </script></div><p>Biologists have long understood the various parts within the cell. But how these parts interact with and respond to each other is largely unknown.</p>
<p>&#8220;We want to understand how cells make decisions, so we can control the decisions they make,&#8221; said Northwestern Engineering&#8217;s <a href="../../../../research-faculty/directory/profiles/bagheri-neda.html" title="More about Professor Bagheri">Neda Bagheri</a>. &#8220;A cell might decide to divide uncontrollably, which is the case with cancer. If we understand how cells make that decision, then we can design strategies to intervene.&#8221;</p>
<p>To better understand the mysterious interactions that occur inside cells, Bagheri and her team have designed a new machine learning algorithm that can help connect the dots among the genes&#8217; interactions inside cellular networks. Called &#8220;Sliding Window Inference for Network Generation,&#8221; or SWING, the algorithm uses time-series data to reveal the underlying structure of cellular networks.</p>
<p>Supported by the National Science Foundation, National Institutes of Health, and Northwestern&#8217;s Biotechnology Training Program, <a href="http://www.pnas.org/content/early/2018/02/08/1710936115" title="Read the journal paper">the research was published online today in the <i>Proceedings of the National Academy of Sciences</i></a>. Justin Finkle and Jia Wu, graduate students in Bagheri&#8217;s laboratory, served as co-first authors of the paper.</p>
<p><img alt="Neda Bagheri" class="image_floatRight" height="250" src="../../../../images/research-and-faculty/directory/bagheri-neda.jpg" width="250"/>In biological experiments, researchers often perturb a subject by altering its function and then measure the subject&#8217;s response. For example, researchers might apply a drug that targets a gene&#8217;s expression level and then observe how the gene and downstream components react. But it is difficult for those researchers to know whether the change in genetic landscape was a direct effect of the drug or the effect of other activities taking place inside the cell.</p>
<p>&#8220;While many algorithms interrogate cue-signal responses,&#8221; Finkle said, &#8220;we used time-series data more creatively to uncover the connections among different genes and put them in a causal order.&#8221;</p>
<p>SWING puts together a more complete picture of the cause-and-effect interactions happening among genes by incorporating time delays and sliding windows. Rather than only looking at the individual perturbations and responses, SWING uses time-resolved, high-throughput data to integrate the time it takes for those responses to occur.</p>
<p>&#8220;Other algorithms make the assumption that cellular responses appear more-or-less uniformly in time,&#8221; Wu said. &#8220;We incorporated a window that includes different temporal ranges, so it captures responses that have dynamic profiles or different delays in time.&#8221;</p>
<p>&#8220;The dynamics are really important because it&#8217;s not just <i>if</i> the cell responds to a certain input, but <i>how</i>,&#8221; Bagheri added. &#8220;Is it slow? Is it fast? Is it a pulse-like or more dynamic? If I introduced a drug, for example, would the cell have an immediate response and then recover or become resistant to the drug? Understanding these dynamics can guide the design of new drugs.&#8221;</p>
<p>After designing the algorithm, Bagheri&#8217;s team validated it in the laboratory in both computer simulations and in vitro in <i>E. coli </i>and <i>S. cerevisiae</i> models. The algorithm is open source and now available online. And although it was initially designed to probe the interior, mysterious life of cells, the algorithm can be applied to many subjects that display activity over time.</p>
<p>&#8220;The framework is not specific to cell signaling or even to biological contexts,&#8221; Bagheri said. &#8220;It can be used in very broad contexts, such as in economics or finance. We expect that it could have a great impact.&#8221;</p></div></div></div>
            </article>
            <div id="news-right-col" role="complementary">
                <div id="right-col-halvsies">
                    
        
        <div id="newsarticle_content_rightside"><!--
                googleoff: index
            --><h4>From our Magazine</h4><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/tech-as-art.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/tech-as-art-t.jpg"/><span>Tech as Art</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/learning-to-succeed.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/learning-to-succeed-t.jpg"/><span>Learning to Succeed</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/head-in-the-clouds .html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/head-in-the-clouds-t.jpg"/><span>Head in the Clouds</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/intellectual-curiosity-and-the-well-trained-mind.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/intellectual-curiousity-t.jpg"/><span>Intellectual Curiosity and the Well-Trained Mind</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/bright-young-and-making-an-impact.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/bright-young-t.jpg"/><span>Bright, Young, and Making an Impact</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/aspiring-engineers-explore-sustainability-in-germany.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/aspiring-engineers-t.jpg"/><span>Aspiring Engineers Explore Sustainability in Germany</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/startups-enjoying-sustainable-growth.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/startups-enjoying-sustainable-growth-t.jpg"/><span>Startups Enjoying Sustainable Growth</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/making-cities-more-accessible-with-human-centered-design.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/making-cities-more-accessible-t.jpg"/><span>Making Cities More Accessible with Human-Centered Design</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/solving-global-problems-with-engineering.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/solving-global-problems-t.jpg"/><span>Solving Global Problems with Engineering</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/summer-research-worth-the-rewards.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/summer-research-t.jpg"/><span>Summer Research: Worth the Rewards</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/secrets-obscured-for-centuries-come-to-light.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/secrets-obscured-t.jpg"/><span>Secrets Obscured for Centuries Come to Light</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/training-ecosystems-taps-power-of-community.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/training-ecosystems-t.jpg"/><span>Training Ecosystem Taps the Power of Community</span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/solving-big-problems-with-big-data.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/solving-big-problems-t.jpg"/><span>Solving Big Problems with Big Data </span></a></div></div><div class="news_list_side"><div><a href="http://www.mccormick.northwestern.edu/magazine/fall-2017/by-water-by-land-by-air.html"><img border="0" src="http://www.mccormick.northwestern.edu/magazine/images/fall-2017/by-water-by-land-t.jpg"/><span>By Water, By Land, By Air</span></a></div></div><!--
                -googleon: index
            --><div class="social lower-side"><h4>Join Us</h4><div><a class="icon-twitter iconset-home" href="http://twitter.com/NorthwesternEng" target="_blank">McCormick on twitter</a><a class="icon-facebook iconset-home" href="http://facebook.com/northwesternengineering" target="_blank">McCormick on facebook</a><a class="icon-google iconset-home" href="https://plus.google.com/112338659769568952865/posts" target="_blank">McCormick on google</a><a class="icon-linkedin iconset-home" href="https://www.linkedin.com/groups?gid=McCormick-School-Engineering-Northwestern-University-51604" target="_blank">McCormick on linkedin</a><a class="icon-rss iconset-home" href="http://mccormick.northwestern.edu/rss/mcc.xml" target="_blank">McCormick on rss</a><a class="icon-youtube iconset-home" href="https://www.youtube.com/user/NUMcCormick" target="_blank">McCormick on youtube</a>
</div></div><div class="newsletter lower-side"><h4>Newsletter </h4><p>Get our news delivered to your inbox.</p><a class="link-bttn" href="/news/newsletter-signup.html" id="newsletter-bttn">Signup</a></div></div>
        
        
    
                    
                </div>
                
            </div>
            <div id="back-to-top">
                <a href="#top">BACK TO TOP</a>
            </div>
        </div>
        <footer class="cf" role="contentinfo"><div class="header-container cf"><a href="http://www.northwestern.edu" id="footer-logo" target="_blank">Northwestern Seal</a><div id="footer-links"><p><span class="footer-branding-element">McCormick School of Engineering,</span>&#160;
                        
                        
                        <span class="footer-branding-element">Northwestern University</span></p><address>Technological Institute, 2145 Sheridan Road, Evanston, IL 60208</address><p class="contact-info white-single-arrow"><a href="../../../../contact/index.html">view all contact info</a></p><ul><li><a href="../../../../academics/apply.html">Admissions</a></li><li><a href="../../../../research-faculty/directory/index.html">Faculty Directory</a></li><li><a href="http://giving.northwestern.edu/node/2668" target="_blank">Give to McCormick</a></li><li><a href="../../../../contact/maps.html">Tech Room Finder / Maps</a></li><li><a href="http://www.mccormick.northwestern.edu/faculty-staff-resources/safety-emergency-information/index.html">Emergency Information</a></li><li><a href="http://www.northwestern.edu" target="_blank">Northwestern Home</a></li><li><a href="http://www.mccormick.northwestern.edu/offices-services/index.html#lost-and-found" target="_blank">Tech Lost and Found</a></li></ul></div><div id="footer-icons"><div id="footer-icon-set1"><a class="icon-twitter iconset-footer" href="http://twitter.com/NorthwesternEng" target="_blank">McCormick on twitter</a><a class="icon-facebook iconset-footer" href="http://facebook.com/northwesternengineering" target="_blank">McCormick on facebook</a><a class="icon-google iconset-footer" href="https://plus.google.com/112338659769568952865/posts" target="_blank">McCormick on google</a></div><div id="footer-icon-set2"><a class="icon-linkedin iconset-footer" href="https://www.linkedin.com/groups?gid=51604" target="_blank">McCormick on linkedin</a><a class="icon-rss iconset-footer" href="http://mccormick.northwestern.edu/rss/mcc.xml" target="_blank">McCormick on rss</a><a class="icon-youtube iconset-footer" href="https://www.youtube.com/user/NUMcCormick" target="_blank">McCormick on youtube</a></div></div></div><div id="footer-copyright"><div class="header-container">
                     &#169; 
                    
                    
                    
                    
                    2018 Robert R. McCormick School of Engineering and Applied Science, Northwestern University 
                    
                    
                    
                    
                    <a href="http://www.northwestern.edu/disclaimer.html" target="_blank">Disclaimer</a></div></div></footer>
        
 
    <!--[if lte IE 9]>
      <script src="/js/media.match.min.js"></script>
      <script src="/js/rem.js"></script>
    <![endif]-->
    <!--[if lte IE 10]>
        <script src="/js/placeholders.js"></script>
    <![endif]-->



<script src="/js/jquery/jquery.fitvids.js"></script>
<script src="/js/breakpoints.js" type="text/javascript"></script>
<script src="/js/modernizr.js" type="text/javascript"></script>
<script src="/js/jquery/jquery-slick-1.3.6.js" type="text/javascript"></script>
 

<script>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</script>

<script src="../../../../js/jquery/jquery.fitvids.js"></script>
<script src="../../../../js/waypoints.min.js"></script>
<script src="../../../../js/jquery/jquery-history.js"></script>
<script src="../../../../js/mq.genie.min.js"></script>
<script src="../../../../js/caption-news.js"></script>
<script>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</script>


<script>

$(document).ready(function() {

  $('.slider:not(.slick-initialized):not(.single-image)').each(function(i, slider) {
    if($(slider).attr('data-randomize') == 'true') {
      $(slider).children('div').shuffle();
    }
    $(slider).slick({
      autoplay: JSON.parse($(slider).attr('data-autoplay')),
      autoplaySpeed: $(slider).attr('data-autoplaySpeed')*1,
      responsive :[ {
        breakpoint: 520,
        settings: {
          dots: true,
        }
      }
      ]
    });
  });

});

  $(document).ready(function() {

    var random_numbers = {};
    var article_count = $('.news_list_side').length;
                
                while( Object.keys( random_numbers ).length < ( article_count - 4 ) ) {
                    random_numbers[ Math.floor( Math.random( ) * article_count ) ] = true; 
                }

                for(num in random_numbers) {
                    $($('.news_list_side')[num]).hide();
                }

    $("#container").fitVids();

  });

function doEightForty() {
    if(underEightForty.matches == true) {
        console.log('doEightForty');
        $('#page-title').after($('#newsletter-bttn'));
        $( "#newsletter-bttn" ).prepend( "<span>Newsletter&nbsp;</span>" );
        $('.back-issues, .issue-pdf, .mailing-list').insertAfter('#container');
      }
    }
    
    function undoEightForty() {
	if(overEightForty.matches == true) {
			console.log('undoEightForty');
		$('.newsletter > p').after($('#newsletter-bttn'));	
		$( "#newsletter-bttn > span" ).remove();	
        $('.back-issues, .issue-pdf, .mailing-list').prependTo('#newsarticle_content_rightside');

		}
	}
	
    function doThreeSixty() {
    if(underThreeSixty.matches == true) {
        console.log('doThreeSixty');
        $('.newsarticle_dateline').after($('.addthis'));
      }
    }
	
    function undoThreeSixty() {
	if(overThreeSixty.matches == true) {
		console.log('undoThreeSixty');
		$('#news_story').prepend($('.addthis'));		
	  }
	}
	
   var underEightForty = window.matchMedia("(max-width: 840px)");
   underEightForty.addListener(doEightForty);

   var overEightForty = window.matchMedia("(min-width: 841px)");
   overEightForty.addListener(undoEightForty);
   
   var underThreeSixty = window.matchMedia("(max-width: 360px)");
   underThreeSixty.addListener(doThreeSixty);

   var overThreeSixty = window.matchMedia("(min-width: 361px)");
   overThreeSixty.addListener(undoThreeSixty);
   
   doEightForty();
   undoEightForty();
   doThreeSixty();
   undoThreeSixty();

</script>   
<script type="text/javascript">

  var _gaq = _gaq || [];
 _gaq.push(['_setAccount', 'UA-3977631-26']);
 _gaq.push(['_trackPageview']);

  _gaq.push(['b._setAccount', 'UA-3977631-1']);
 _gaq.push(['b._trackPageview']);

  _gaq.push(['_setDomainName', '.northwestern.edu']);

  (function() {
    var ga = document.createElement('script'); ga.type = 'text/javascript'; ga.async = true;
    ga.src = ('https:' == document.location.protocol ? 'https://ssl' : 'http://www') + '.google-analytics.com/ga.js';
    var s = document.getElementsByTagName('script')[0]; s.parentNode.insertBefore(ga, s);
  })();

</script>


<script src="/js/mti-tracking.js" type="text/javascript"></script>
 

    </body>
</html>